产品手册

OT Heavy 用户手册

本手册按产品菜单逐一介绍 OT Heavy 的功能和操作步骤。书中截图均取自 OT Heavy 8.0.9 的实际运行界面,示例数据为系统预置的演示数据;红框和编号标出的是操作位置。

适用版本
OT Heavy 8.0.9(界面显示为"标准版 8.0.9")
适用读者
业务用户、数据维护人员、系统管理员
推荐浏览器
Chrome 最新版
界面语言
简体中文(产品支持 21 种界面语言)

第 1 章简介

OT Heavy 是一款面向业务人员的数据分析与知识应用平台。用户可以像使用搜索引擎一样输入关键词查询数据,系统会自动生成图表;也可以用自然语言向"小慧"提问,或者与本体智能体对话,让它结合业务数据和文档给出分析结论。分析结果可以保存为历史问答,组合成数据看板,并按计划推送给相关人员。OT Heavy 还集成了 DataSpring ETL,可以把各种数据源的数据抽取、转换后加载到目标系统。

本章介绍如何登录系统、认识主界面,以及首页"本体工作台"的基本用法。

1.1系统登录

1.1.1登录

  1. 在浏览器中打开管理员提供的访问地址(形如 https://服务器地址:31600),进入登录页面,如 图 1-1 所示。建议使用 Chrome 浏览器。
  2. 在①处输入账号,在②处输入密码。
  3. 点击③处的"登录"按钮,进入系统首页。
登录页面
图 1-1 登录页面

说明:管理员首次登录时,系统会要求修改默认密码,修改完成后才能继续使用。

1.1.2忘记密码

在登录页面点击"忘记密码?",打开忘记密码页面,如 图 1-2 所示:

  1. 输入用户名和账号绑定的邮箱。
  2. 点击"发送验证码",到邮箱中查收验证码并填入。
  3. 输入新密码,并再次输入确认。
  4. 点击"确定"完成重置,之后用新密码登录。
忘记密码
图 1-2 忘记密码

说明:找回密码需要系统已经配置邮件服务器(见"系统管理 > 全局配置")。如果收不到验证码,请联系系统管理员重置密码。

1.1.3退出登录

点击页面右上角的用户名,在下拉菜单中选择"退出",如 图 1-10 中③处所示。

1.2界面介绍

登录后的主界面分为三个区域,如 图 1-3 所示:

  • ① 顶部导航栏:左侧是产品标志和"导航列表"按钮,右侧是消息、帮助、语言切换和当前用户。
  • ② 左侧菜单栏:进入各功能模块的入口。
  • ③ 工作区:显示当前模块的内容。
主界面布局
图 1-3 主界面布局

1.2.1左侧菜单栏

左侧菜单栏以图标显示,鼠标悬停时显示菜单名称。各菜单的作用如下:

菜单 作用 详见
首页 本体工作台,可直接与本体智能体对话 本章 1.3 节
BI 工作台 包含数据搜索、智能问数、历史问答、数据看板四个子菜单 第 2~5 章
数据表管理 导入和维护数据表、数据集、指标公式及外部数据源 第 6 章
数据填报 创建填报表单,收集和管理填报数据 第 7 章
定时发送 把问答、看板等内容定时推送到企业微信、钉钉、飞书 第 8 章
资源管理 按项目组织问答、看板、数据应用和数据表 第 9 章
本体管理 创建本体,管理本体的智能体、图谱、文档、指标和控制面板 第 10 章
日志管理 查看系统操作日志 第 11 章
数据治理 查看数据资产目录、资产全景,管理数据服务 API 第 12 章
DataSpring ETL 用任务流对数据进行抽取、清洗、转换和加载,可定时运行 第 13 章
系统管理 用户、角色、权限及各项系统配置 第 14 章
回收站 恢复或彻底删除已删除的看板、数据应用和卡片 第 15 章

"BI 工作台"是一个菜单组。点击①处的图标展开后,可以看到②处的四个子菜单,从上到下依次是数据搜索、智能问数、历史问答和数据看板,如 图 1-4 所示。再次点击即可收起。

BI 工作台子菜单
图 1-4 BI 工作台子菜单

说明:不同账号能看到的菜单取决于管理员分配的角色和权限,本手册截图使用的是系统管理员账号。

1.2.2顶部导航栏

顶部导航栏各按钮的位置如 图 1-5 所示:

顶部导航栏
图 1-5 顶部导航栏
  • ① 导航列表:配置显示在导航上的数据看板和数据应用。点击后进入导航列表页面,如 图 1-6 所示:左侧是当前已配置的导航项,右侧列出可用的数据看板和数据应用,拖拽到左侧后点击"确定"即可。
  • ② 消息盒:显示最近的系统消息,如 图 1-7 所示。点击"清空"可清除消息,点击"查看全部"进入消息通知页面。
  • ③ 帮助:提供"用户手册""DataFocus教程""DataFocus社区"的链接,以及"DataFocus版本"信息,如 图 1-8 所示。
  • ④ 语言切换:选择界面语言,如 图 1-9 所示。产品支持简体中文、繁體中文、English、日本語、한국어等 21 种界面语言。
  • ⑤ 当前用户:点击用户名打开用户菜单,如 图 1-10 所示,包含①"用户信息"、②"消息通知"和③"退出"。
导航列表
图 1-6 导航列表
消息盒
图 1-7 消息盒
帮助菜单
图 1-8 帮助菜单
语言切换
图 1-9 语言切换
用户菜单
图 1-10 用户菜单

1.2.3用户信息

在用户菜单中点击"用户信息",打开"修改用户信息"窗口,如 图 1-11 所示。在这里可以:

  • 点击头像下方的"更换"上传新头像;
  • 修改真实名称;
  • 点击邮箱一栏的"修改"更换邮箱;
  • 填写手机号。
修改用户信息
图 1-11 修改用户信息

1.2.4消息通知

在用户菜单中点击"消息通知",或在消息盒中点击"查看全部",进入消息通知页面,如 图 1-12 所示。页面顶部的"所有""告警""通知"三个页签用于按类型筛选消息。

消息通知
图 1-12 消息通知

1.3首页

点击左侧菜单栏的"首页"图标,进入本体工作台,如 图 1-13 所示。页面分为两部分:

  • ① 与本体对话:向当前本体的智能体提问。输入框上方的"@ 本体名称"标签表示当前对话的本体。
  • ② 本体工作台:以办公室场景展示各个本体智能体的状态,顶部统计"高亮""工作中""休息中"的智能体数量。右上角的"知识库"图标跳转到当前本体的本体图谱,"文件夹"图标跳转到当前本体的文档中心。
首页本体工作台
图 1-13 首页本体工作台

1.3.1与本体对话

  1. 在左侧输入框中输入问题,例如"当前采购审批流程有哪些瓶颈?"。
  2. 按 Enter 键或点击输入框右下角的发送按钮。
  3. 智能体会显示处理步骤,并在完成后给出回答。回答中引用的数据来自本体绑定的数据表和文档。
  4. 点击回答下方的"查看处理过程",可以展开智能体查询了哪些数据、调用了哪些工具,见第 10 章 图 10-3 中④处。

说明:本体智能体需要管理员在系统中配置大模型服务后才能使用;回答通常需要几十秒,问题越复杂,耗时越长。本体的创建和维护见第 10 章。

第 2 章数据搜索

数据搜索是 OT Heavy 最常用的功能:选好数据表后,在搜索框中输入列名和关键词,系统会立即计算结果并自动选择合适的图表。例如输入"区域 销售金额",就能得到各区域销售金额的汇总图。搜索结果可以切换图形、调整配置,也可以保存为历史问答或加入数据看板。

在左侧菜单栏展开"BI 工作台",点击"数据搜索"进入本页面。

2.1选择数据表

搜索前要先选择数据来源。

  1. 点击页面左上方的"选择数据"按钮,打开选择窗口,如 图 2-1 所示。
  2. 在①处"选择数据表"页签下,勾选要使用的数据表,例如"电商销售数据"。已选中的表会显示在上方②处"已选择的数据表"区域。如需从已建好的数据集中选择,可切换到"选择数据集"页签。
  3. 点击③处"确定"。
选择数据表
图 2-1 选择数据表

选择完成后,页面左侧会列出这张表的所有列,如 图 2-2 所示:

  • ① 选择数据:重新选择数据表。
  • ② 当前数据表:显示已选择的表名,点击右侧箭头可以收起或展开列清单。
  • ③ 属性列:文字、日期、地理等描述性的列,例如产品、区域、订单日期,通常用来分组和筛选。
  • ④ 度量列:数值型的列,例如销售金额、销售数量,搜索时默认按总和汇总。
  • ⑤ 预览数据:查看表中的部分数据,见 2.6 节。
  • ⑥ 重载索引:数据表内容更新后,可以点击这里刷新搜索联想所用的索引。
  • ⑦ 搜索框:输入搜索语句。
已选择数据表的搜索页面
图 2-2 已选择数据表的搜索页面

搜索框下方会给出推荐的搜索语句,按"我的常搜""做对比""看变化"等分类展示,点击即可直接搜索。

2.2输入搜索语句

在搜索框中输入列名和关键词,词与词之间用空格分隔。输入时,系统会在搜索框下方给出联想提示(包括历史记录),如 图 2-3 所示,可以直接点击选用。被识别的列名和关键词会变成带底色的标签。

输入时的联想提示
图 2-3 输入时的联想提示

输入完成后按 Enter 键执行搜索。常用写法举例如下:

搜索语句 含义 默认图形
区域 销售金额 按区域汇总销售金额 饼图
每月 销售金额 按订单日期逐月汇总销售金额 折线图
产品子类别 销售数量 按产品子类别汇总销售数量 饼图
省份 销售金额 按省份汇总销售金额 地图

"每月""每年""前 10"等关键词的完整用法,请点击页面右上角"帮助"菜单中的"用户手册",参考其中的关键词说明。

说明:如果输入的内容不是标准的列名和关键词(例如一句完整的问话),系统会自动请"小慧"把它解析成搜索语句,见 2.4 节。

2.3搜索结果

搜索完成后,页面显示结果图表,标题为搜索语句,右上方显示"搜索记录数",如 图 2-4 所示:

  • ① 搜索框:当前的搜索语句,可以继续修改后重新搜索。
  • ② 工具栏:对结果进行加入看板、切换显示方式、保存等操作。
  • ③ 右侧配置栏:调整图表属性、筛选条件、图轴,查看 SQL 和小慧分析总结。
  • ④ 归因分析:分析指标变化的原因,见 2.5 节。
搜索结果页面
图 2-4 搜索结果页面

2.3.1工具栏

工具栏各按钮如 图 2-5 所示。最左侧的图标是"加入数据简报",把当前结果作为一条简报内容收藏,可选择缩略图靠左或靠右并填写备注。其余按钮依次为:

  • ① 添加到数据看板:把结果加入某个数据看板,见 2.7 节。
  • ② 表格:以明细表格显示结果。
  • ③ 图形切换:更换图表类型。
  • ④ 更多:保存为中间表、导出数据、导出图片、数据转换、刷新数据。
  • ⑤ 保存:保存为历史问答,见 2.7 节。
结果工具栏
图 2-5 结果工具栏

2.3.2切换图形

系统会根据结果的数据特征自动选择图形,也可以手动更换:

  1. 点击工具栏中的"图形切换"按钮(图 2-6 中①处),打开图形面板。面板顶部显示可用的图表类型数量,左侧按饼图、折线图、柱状图、散点图、仪表图、面积图、热力图、地图、3D 图等分类。
  2. 在左侧选择分类(如②处"柱状图"),再点击右侧具体的图形。
  3. 图表立即切换为所选样式,如 图 2-7 所示。
图形切换面板
图 2-6 图形切换面板
切换为柱状图
图 2-7 切换为柱状图

2.3.3以表格显示

点击工具栏中的"表格"按钮,结果以表格形式显示,如 图 2-8 所示。点击列标题右侧的箭头可以排序,点击齿轮图标可以设置该列。再次点击"图形切换"即可回到图表。

以表格显示结果
图 2-8 以表格显示结果

2.3.4右侧配置栏

右侧配置栏从上到下有五个按钮,点击后在结果右侧展开对应面板,再次点击即可收起。

图表属性:调整图表的外观,包括通用、颜色、X 轴、Y 轴、网格线配置、数据标签、悬浮文本设置、标度(参考线)、分析器配置、扩展搜索结果和定时刷新,如 图 2-9 所示。

图表属性
图 2-9 图表属性

筛选:按列设置筛选条件,如 图 2-10 所示。每一列都可以展开"筛选""配置""排序"等选项;度量列还可以设置"颜色规则""告警"和"聚合方式"(例如把总和改为平均值)。

筛选
图 2-10 筛选

图轴配置:指定哪些列作为 X 轴、Y 轴、右 Y 轴和图例,如 图 2-11 所示。把列拖到对应位置即可;暂时不想显示的列可以拖到"未可视化的列"。

图轴配置
图 2-11 图轴配置

查询 SQL 语句:显示本次搜索实际执行的 SQL 和计算耗时,便于核对口径,如 图 2-12 所示。

查询 SQL 语句
图 2-12 查询 SQL 语句

小慧分析总结:由小慧对当前结果做文字解读,分"总结"和"见解"两个页签。例如对各区域销售金额,小慧会指出排名靠前的区域及其占比。

2.3.5更多操作

点击工具栏中的"…"按钮,弹出更多操作菜单,如 图 2-13 所示:

  • 保存为中间表:把当前结果保存成一张新的数据表,供后续搜索使用。
  • 导出数据:把结果数据下载到本地。
  • 导出图片:把图表下载为图片。
  • 数据转换:对结果数据做进一步的转换处理。
  • 刷新数据:重新执行查询,获取最新数据。
更多操作
图 2-13 更多操作

2.4小慧智能解析

除了输入列名和关键词,也可以直接用自然语言提问,例如"华东地区每个省份的销售金额是多少"。按 Enter 后,小慧会把问题解析成标准的搜索语句并执行,搜索框下方显示提示"小慧刚刚将您的输入……解析成了……"。例如这个问题会被解析为"销售金额 总和 按 省份 区域 = "华东"",并以地图展示华东各省的销售金额。

提示条右侧有三个操作:

  • 恢复:撤销小慧的解析,回到自己输入的原始内容;
  • 点赞:对本次解析给出正面反馈;
  • ×:关闭提示条。

说明:输入标准搜索语句时,小慧也会在后台再解析一次;如果解析结果与原输入不同,同样会出现上述提示,并以解析后的语句显示结果。若想保留自己的写法,点击"恢复"即可。

2.5时序预测与归因分析

2.5.1时序预测

当结果按时间展示(例如"每月 销售金额")时,结果左下角会出现"时序预测"按钮。点击后,系统根据历史数据预测后续几期的数值,并以红色虚线接在原曲线之后,如 图 2-14 所示。

时序预测
图 2-14 时序预测

2.5.2归因分析

点击结果左下角的"归因分析",打开归因分析窗口,如 图 2-15 所示。窗口提供"贡献度归因"和"夏普利渠道归因"两种方法:

  1. 在"归因指标"中选择要分析的指标,例如"销售金额(总和)"。
  2. 在"归因维度"中勾选可能影响指标的列,例如产品子类别、区域、快递公司。
  3. 选择"检测日期",并设置"归因日期"和"对齐日期"的范围。
  4. 点击"确定",系统给出各维度对指标变化的贡献。
归因分析
图 2-15 归因分析

2.6预览数据与增加公式

2.6.1预览数据

点击左侧列清单上方的"预览数据",可以查看当前数据表中随机抽取的数据,并显示总记录数,如 图 2-16 所示。

预览数据
图 2-16 预览数据

2.6.2增加公式

如果需要在搜索中使用表里没有的计算结果,可以点击左下角的"增加公式",打开"添加指标公式"窗口,如 图 2-17 所示:

  1. 填写公式名。
  2. 在公式输入框中输入表达式,可以使用上方的运算符;输入时下方会列出可用的列和函数,点击即可插入。点击"公式辅助"可以查看函数说明。
  3. 点击"确定"。新公式会出现在左侧列清单中,可以像普通列一样搜索。
添加指标公式
图 2-17 添加指标公式

2.7保存与加入看板

2.7.1保存为历史问答

满意的搜索结果可以保存下来,以后直接打开查看:

  1. 点击工具栏中的"保存"按钮,打开"保存为历史问答"窗口,如 图 2-18 所示。
  2. 在①处填写名称(默认为搜索语句),可以补充描述。
  3. 在②处"管理项目"中,可以点击"选择其他管理项目"把问答归入某个项目(项目见第 9 章);不选择则为"无管理项目"。
  4. 点击"确定"。保存成功后,系统提示"成功保存历史问答",可以点击"跳转到项目中查看"。
保存为历史问答
图 2-18 保存为历史问答

保存后的问答在"历史问答"中管理,见第 4 章。

2.7.2添加到数据看板

点击工具栏中的"添加到数据看板"按钮,打开"添加到数据看板"窗口,如 图 2-19 所示:

  1. 填写名称,即这张图在看板上显示的标题。
  2. 在"数据看板"列表中选择一个已有的看板;如果还没有看板,点击"创建数据看板"新建一个。
  3. 点击"确定"。
添加到数据看板
图 2-19 添加到数据看板

数据看板的使用方法见第 5 章。

第 3 章智能问数

智能问数是与 AI 助手"小慧"对话式分析数据的页面。不需要记住列名和关键词,直接用日常语言提问,小慧会理解问题、选择数据并给出分析结果;也可以让小慧生成分析报告。

在左侧菜单栏展开"BI 工作台",点击"智能问数"进入本页面。

3.1页面介绍

智能问数页面包括以下部分:

  • 新建会话:页面左上角,开始一个新的对话。
  • 会话列表:列出历史会话,显示会话标题和时间,可以按关键词搜索;点击会话即可继续之前的对话。
  • 输入框:页面中部,输入问题,按 Enter 或点击右下角的发送按钮。左侧的麦克风图标可以语音输入,右侧的回形针图标可以添加附件。
  • 智能研究报告:输入框下方,选择报告模式,"标准"或"深度(兼容模式)",见 3.3 节。
  • 我的知识库:页面左下角,管理自己补充给小慧的业务知识,见 3.4 节。
  • 我的分析报告:页面左下角,查看小慧生成过的分析报告,见 3.5 节。

3.2向小慧提问

  1. 点击"新建会话",在输入框中输入问题,例如"请按区域统计电商销售数据的销售金额,生成柱状图,并说明哪个区域最高。",按 Enter 发送。

  2. 小慧先选择要使用的数据表,过程中显示"正在加载数据表:电商销售数据..."。如果小慧无法确定使用哪张数据表,会列出可能的数据表请你选择,点击其中一张即可。

  3. 等待小慧查询数据,通常需要一两分钟。回答包括:

    • 搜索语句:小慧把问题转换成的搜索语句,例如"区域 销售金额"。下方一行说明它把你的输入解析成了什么,可以据此判断小慧是否理解对了。
    • 工具栏:与数据搜索结果的工具栏相同,依次为添加到数据看板、表格、图形切换、保存为历史问答,用法见 2.7 节。
    • 结果图表:例如各区域销售金额的柱状图。
    • 小慧分析总结:用文字概括结果,例如哪个区域最高、占比多少。点击下方的复制按钮可以复制总结。

    本次使用的数据表显示在会话列表中本次会话的下方。

  4. 可以在同一会话中继续追问;点击回答下方的点赞或点踩图标,可以反馈回答是否有帮助。

提示:问题中尽量包含具体的指标、维度和时间范围,例如"2025 年各区域的销售目标完成情况",小慧的回答会更准确。页面底部"内容由 AI 生成,请仔细甄别"提醒:重要结论请到数据搜索中核对。

3.3智能研究报告

需要一份完整的分析报告时,在输入框下方的"智能研究报告"中选择模式,再描述报告需求:

  • 标准:生成常规分析报告;
  • 深度(兼容模式):进行更深入的多步分析,耗时更长。

生成的报告可以在"我的分析报告"中查看。

3.4我的知识库

点击页面左下角的"我的知识库",打开"查看我的知识库"窗口,如 图 3-1 所示。在这里可以把业务口径、术语解释等知识告诉小慧:

  1. 点击"新增知识"逐条添加,或点击"批量导入"一次导入多条。
  2. 每条知识包括知识内容、关键词、类型、分类,可以设置是否启用。
  3. 可以按关键词或知识分类查找已有知识。
我的知识库
图 3-1 我的知识库

系统管理员可以在"系统管理 > 知识库"中管理全系统共享的知识,见第 14 章。

3.5我的分析报告

点击页面左下角的"我的分析报告",打开"查看我的分析报告"窗口,如 图 3-2 所示。"智能研究报告"页签列出正在生成和已生成的报告任务,"历史报告"页签列出以往的报告。

我的分析报告
图 3-2 我的分析报告

第 4 章历史问答

保存后的搜索结果称为"历史问答"。历史问答记录了数据来源、搜索语句和图表设置,打开时会按最新数据重新计算,因此可以作为常用报表反复查看,也可以加入数据看板、分享给同事或定时推送。

在左侧菜单栏展开"BI 工作台",点击"历史问答"进入问答列表。

4.1问答列表

问答列表以卡片形式展示所有历史问答,如 图 4-1 所示:

  • ① 分类页签:"所有""我的""收藏""分享""公开",分别显示全部问答、自己创建的、自己收藏的、别人分享给自己的和已公开的问答。
  • ② 创建:新建历史问答,会跳转到数据搜索页面。
  • ③ 搜索框:按名称查找问答。
  • ④ 标签:按标签筛选问答。
  • ⑤ 筛选:按"最新时间"或"浏览次数"排序。
历史问答列表
图 4-1 历史问答列表

4.2问答操作

把鼠标移到问答卡片上,卡片顶部会出现一排操作按钮,中间出现"编辑"按钮,如 图 4-2 所示:

编号 按钮 作用
① 公开 把问答设为公开,公开后所有用户都能在"公开"页签中看到;再次点击取消公开
② 分享 生成外部链接,或分享给其他用户,见 4.4 节
③ 收藏 收藏后可在"收藏"页签中快速找到
④ 复制 复制出一个新的问答
⑤ 更改所有者 把问答转交给其他用户
⑥ 移动 把问答移动到某个项目中
⑦ 删除 删除问答
⑧ 编辑 打开问答进行查看和修改
问答卡片上的操作按钮
图 4-2 问答卡片上的操作按钮

点击卡片名称右侧的铅笔图标,可以直接修改问答名称。

4.3查看与修改问答

  1. 在问答卡片上点击"编辑",打开问答,如 图 4-3 所示。①处标题为问答名称。
  2. 打开后的页面与数据搜索相同,可以修改搜索语句、切换图形、调整配置,操作方法见第 2 章。
  3. 修改完成后点击②处"保存",覆盖原问答。
打开的历史问答
图 4-3 打开的历史问答

4.3.1评论

在打开的问答中,点击工具栏最左侧的"评论"按钮(图 4-4 中①处),可以查看其他用户的评论,也可以输入评论内容后点击"发送评论"。

问答评论
图 4-4 问答评论

4.4分享问答

在问答卡片上点击"分享"按钮,打开分享窗口,如 图 4-5 所示。窗口有两个页签:

外部链接分享:生成一个可以在浏览器中直接打开的链接。

  1. 选择链接的有效期:1 天、7 天、30 天或永久有效。
  2. 设置校验码,可点击"随机生成"。设置后,访问者需要输入校验码才能查看;不设置则任何拿到链接的人都能访问。
  3. 点击"创建链接",复制生成的链接发给对方。

分享给其他用户:选择系统中的其他用户,被分享的用户可以在自己的"分享"页签中看到该问答。

分享历史问答
图 4-5 分享历史问答

说明:外部链接不需要登录即可访问,请妥善设置有效期和校验码,避免数据外泄。

4.5移动、更改所有者与删除

4.5.1移动到项目

点击"移动"按钮,打开"移动历史问答"窗口,如 图 4-6 所示。在列表中选择目标项目,点击"确定"。项目的创建方法见第 9 章。

移动历史问答
图 4-6 移动历史问答

4.5.2更改所有者

点击"更改所有者"按钮,在窗口中搜索并选择新的所有者,点击"确定",如 图 4-7 所示。更改后,问答归新所有者管理。

更改所有者
图 4-7 更改所有者

4.5.3删除问答

点击"删除"按钮,系统弹出确认窗口,如 图 4-8 所示。确认无误后点击"确定"。

删除历史问答
图 4-8 删除历史问答

注意:历史问答删除后无法恢复,也不会进入回收站。如果该问答已被加入数据看板,请先确认看板不再需要它。

第 5 章数据看板

数据看板把多个历史问答、文本、筛选器等组件组合在一个页面上,用于日常监控和汇报展示。本章以演示看板"手册示例_电商销售概览"为例,介绍看板的创建、编辑和查看。

在左侧菜单栏展开"BI 工作台",点击"数据看板"进入看板列表。

5.1看板列表

看板列表如 图 5-1 所示:

  • ① 类型页签:数据看板、数据应用、轮播看板、卡片、智能洞察,后四种见 5.5 节。下方的"所有""我的""收藏""分享""公开"用于筛选看板,"所有模板""我的模板""系统模板"用于查看看板模板。
  • ② 模板创建:从已有模板创建看板。
  • ③ 创建数据看板:新建一个空白看板。
数据看板列表
图 5-1 数据看板列表

与历史问答一样,把鼠标移到看板卡片上可以进行分享、收藏、复制、移动、删除等操作,方法见第 4 章。删除的看板会进入回收站,可以恢复。

5.2创建数据看板

  1. 在看板列表点击"创建数据看板",系统新建一个"未命名看板",并打开看板编辑器,如 图 5-2 所示。
  2. 在右侧"全局配置"中填写"看板名称",例如"手册示例_电商销售概览",可以补充描述。
  3. 从左侧问答列表中,把需要的历史问答拖到中间画布上。每拖入一个问答,画布上就多一个图表组件。
  4. 调整组件的大小和位置,见 5.3 节。
  5. 点击右上角"保存"。

编辑器各区域如下:

  • ① 组件栏:问答、文本、筛选、媒体、素材、组件、卡片、模板、图层,点击后在②处显示对应的可用内容。
  • ② 素材列表:当前显示"问答",即可以拖入的历史问答;点击"新增问答"可以直接去搜索并保存新的问答。
  • ③ 画布:看板内容。画布上的横线"首屏参考线"标出打开看板时第一屏能看到的范围。
  • ④ 全局配置:看板名称、描述、布局方式、主题、尺寸、背景颜色、问答查询策略、定时刷新、封面等,并可"存为模板"。
  • ⑤ 顶部操作:"小慧报告助手"、"预览"、"实时保存"和"保存"。勾选"实时保存"后,每次修改都会自动保存。
看板编辑器
图 5-2 看板编辑器

5.2.1全局配置说明

配置项 说明
布局 "网格布局"时组件按网格对齐;"自由布局"时组件可以任意摆放
切换主题 选择看板配色方案(类型 0~类型 6)
看板尺寸、屏幕适应 设置看板宽高,以及在不同屏幕上按宽度或宽高自适应
看板背景、视窗背景、组件背景、组件文字 设置各部分的颜色,背景也可以使用图片
问答查询策略 设置看板中问答的取数方式,例如"缓存优先策略"
定时刷新 勾选后看板按设定的间隔自动刷新数据
缩略图 上传或自动生成看板封面,支持 jpg、png、gif,比例 16:9
存为模板 把当前看板保存为模板,以后可以"模板创建"

5.3编辑组件

5.3.1调整大小与位置

点击画布上的组件即可选中它;组件互相重叠不好选中时,可以点击组件栏中的"图层",在图层列表里按名称选中。选中后,如 图 5-3 所示:

  • ① 图层列表:列出看板上的全部组件,点击名称即可选中。
  • ② 组件工具条:显示在组件上方,可以切换"网格"或"自由"摆放方式、"替换问答",以及上移、下移、复制、锁定、删除等。
  • ③ 组件配置:右侧面板切换为该组件的配置,"尺寸"中的 W、H 是宽和高,"位置"中的 X、Y 是组件左上角在画布上的坐标,输入数值后按 Enter 生效;也可以直接拖动组件四周的控制点调整大小,拖动组件本身移动位置。
选中组件后的工具条与配置
图 5-3 选中组件后的工具条与配置

组件配置面板还包括旋转、圆角、内边距、透明度、背景、边框、阴影和标题样式;切换到"图表"页签可以调整该图表的显示,切换到"跳转"页签可以设置点击图表时的跳转行为。

5.3.2右键菜单

在组件上单击鼠标右键,弹出快捷菜单,如 图 5-4 所示:

  • 编辑问答:打开该问答进行修改;
  • 成组:把多个选中的组件组合在一起;
  • 删除、复制;
  • 存为卡片:把组件保存为卡片,以后可以在其他看板中复用;
  • 上一层、下一层、置顶、置底:调整组件的叠放顺序。
组件右键菜单
图 5-4 组件右键菜单

5.3.3添加筛选器和其他组件

点击组件栏中的"筛选",可以向看板添加筛选器,如 图 5-5 所示。可选的筛选组件共 15 种,包括通用筛选、筛选文本、筛选列表、筛选下拉框、模糊/精确查询、日期区间、动态日期、年份、季度、年月、年月区间、日期等。添加后,查看看板的用户可以通过筛选器统一过滤看板上的图表。

筛选组件
图 5-5 筛选组件

点击组件栏中的"组件",可以添加空白组件、搜索组件、自定义背景、时间器、Tab 控件、Iframe 组件、小慧组件、显示/隐藏组和表格组件,如 图 5-6 所示。"文本""媒体""素材"分别用于添加文字说明、图片视频和装饰素材。

其他组件
图 5-6 其他组件

5.4查看看板

在看板列表中点击看板卡片,或在编辑器中点击"预览",即可查看看板,如 图 5-7 所示。看板中的图表按全局配置里的"问答查询策略"取数;需要最新数据时,可以在全局配置中开启"定时刷新"。点击左上角"返回列表"回到看板列表。

查看数据看板
图 5-7 查看数据看板

5.5数据应用、轮播看板、卡片与智能洞察

看板列表顶部的其他页签提供另外几种展示形式。

模板:点击"模板创建"后进入模板页,"系统模板"是产品自带的模板,"我的模板"是自己"存为模板"的看板,也可以点击"上传模板"导入模板文件,如 图 5-8 所示。

看板模板
图 5-8 看板模板

数据应用:把多个看板组织成带菜单的应用,适合做成部门门户或专题系统。可以通过"模板创建"或"空白创建"新建,如 图 5-9 所示。

数据应用
图 5-9 数据应用

轮播看板:让多个看板在大屏上按设定顺序自动轮流播放。点击"增加轮播看板"创建,如 图 5-10 所示。

轮播看板
图 5-10 轮播看板

卡片:通过组件右键菜单"存为卡片"保存的组件,可以在不同看板中重复使用,如 图 5-11 所示。

卡片
图 5-11 卡片

智能洞察:查看由小慧生成的智能洞察看板,如 图 5-12 所示。

智能洞察
图 5-12 智能洞察

第 6 章数据表管理

数据表是数据搜索、看板和本体使用的数据来源。在"数据表管理"中,可以导入本地文件或数据库中的表,维护列的类型和搜索属性,查看表被哪些问答和看板使用,还可以基于已有的表创建中间表、视图和数据集。

点击左侧菜单栏的"数据表管理"进入本模块。

6.1数据表列表

数据表列表如 图 6-1 所示:

  • ① 功能页签:数据表、数据集、数据表任务、指标公式、外部数据源。
  • ② 新建按钮:导入表、创建中间表、创建视图。
  • ③ 筛选条件:按类型、导入方式、状态筛选,按时间排序;右上方还可以按名称或标签搜索。
  • ④ 卡片操作:鼠标移到数据表卡片上,会出现"详情"和"前往搜索"按钮。点击"详情"查看和维护表结构,点击"前往搜索"以这张表为数据源进入数据搜索。卡片右上角另有收藏、更改所有者、移动、删除等图标。
数据表列表
图 6-1 数据表列表

卡片上显示数据表的大小和规格(行数 × 列数)。带"预置"标记的是系统自带的示例表。

6.2导入数据表

点击"导入表",可以选择四种导入方式,如 图 6-2 所示:

  • 从本地导入表:上传 CSV、Excel 或 JSON 文件;
  • 从数据源导入表:从已连接的数据库中选择表导入,见 6.6 节;
  • 从 API 导入表:通过接口获取数据;
  • HTTP 接入源:配置 HTTP 方式接入的数据。
导入表的方式
图 6-2 导入表的方式

6.2.1从本地导入表

下面以导入"手册示例_门店月度销售.csv"为例:

  1. 点击"导入表",选择"从本地导入表",打开"导入本地文件"窗口。
  2. 选择文件格式(CSV、EXCEL 或 JSON),点击"请选择文件"选择本地文件,文件名会显示在①处,如 图 6-3 所示。文件大小需小于 50 MB。
  3. 点击②处"上传"。
选择本地文件
图 6-3 选择本地文件
  1. 设置文件解析方式,如 图 6-4 所示:选择分隔符(CSV 通常为逗号),确认"您的列信息是否定义在表头"(第一行是列名时勾选),以及是否忽略空行、忽略错误数据、丢弃最后一列后面的多余数据。点击"显示/隐藏高级配置"可以设置更多选项。完成后点击"下一步"。
设置解析方式
图 6-4 设置解析方式
  1. 确认表名和列信息,如 图 6-5 所示。可以修改表名、添加描述;在列表中勾选要导入的列,调整列名和数据类型(如 string、int、double),右侧显示示例值。点击"预览"可以查看导入效果。
  2. 点击①处"确定"完成导入。
确认表名和列
图 6-5 确认表名和列

导入完成后,新表出现在数据表列表的第一位,如 图 6-6 所示。

导入完成
图 6-6 导入完成

说明:如果列名与系统的搜索关键词重名,系统会自动在列名后加上序号。例如本例中的"月份"列被导入为"月份_1",以免与关键词"月份"冲突。导入后可以在表详情中修改列的显示名称。

6.3数据表详情

在数据表卡片上点击"详情",进入数据表详情页,如 图 6-7 所示:

  • ① 详情页签:列信息、关联关系、预览数据、依赖关系、搜索扩展、导出任务。
  • ② 列信息:逐列设置显示名称、数据类型、描述、列类型、聚合方式、数据格式、地域类型、同义词、索引类型、优先级,以及是否"对模型可见"。
  • ③ 添加指标公式列:在表中增加由公式计算的列。
  • ④ 操作:更多操作菜单,例如"智能洞察"。
数据表详情——列信息
图 6-7 数据表详情——列信息

6.3.1列信息

列信息决定了这张表在搜索中的表现,常用设置如下:

设置项 说明
显示名称 搜索时使用的列名,可以改成业务人员熟悉的叫法
列类型 "属性列"用于分组和筛选,"度量列"用于汇总计算
聚合 度量列的默认汇总方式,例如总和
数据格式 数值、日期等的显示格式
地域类型 标记省、市等地理列,搜索时可以用地图展示
同义词 为列名增加同义词,多个同义词用逗号分隔,搜索时输入同义词也能识别
索引类型 是否为列中的值建立搜索联想索引
对模型可见 是否允许小慧等大模型功能使用该列

点击右上角"操作",可以对整张表执行"智能洞察"等操作,如 图 6-8 所示。

数据表操作菜单
图 6-8 数据表操作菜单

6.3.2关联关系

"关联关系"页签用于建立表与表之间的连接,建立后可以在一次搜索中同时使用多张表的列,如 图 6-9 所示。

关联关系
图 6-9 关联关系

点击"添加关联",打开"增加关联关系"窗口,如 图 6-10 所示:

  1. 源表默认为当前表;选择连接方式(如"内连接"),再选择要关联的维度表。
  2. 分别选择源列和维度列,即两张表中用于匹配的列。
  3. 需要时可以开启"动态关联",或设置连接筛选条件。
  4. 点击"预览"检查结果,确认后点击"确定"。
增加关联关系
图 6-10 增加关联关系

点击"查看所有关联关系"可以查看系统中所有表的关联情况。

6.3.3预览数据

"预览数据"页签显示表中随机抽取的 30 条数据,底部显示总记录数,如 图 6-11 所示。

预览数据
图 6-11 预览数据

6.3.4依赖关系

"依赖关系"页签列出使用了这张表的数据看板、历史问答等对象,以及它们的创建者、所属项目和更新时间,如 图 6-12 所示。修改或删除数据表前,建议先在这里确认影响范围。

依赖关系
图 6-12 依赖关系

6.3.5搜索扩展

"搜索扩展"页签用于让搜索更懂业务用语,如 图 6-13 所示:

  • 自定义列中值的同义词:例如把列值"华南"的同义词设为"南方区域",搜索"南方区域"时也能匹配"华南"。点击"新增列中值的同义词"添加。
  • 自定义关键词:为当前表定义专用的搜索关键词。
搜索扩展
图 6-13 搜索扩展

6.3.6导出任务

"导出任务"页签用于把表中的数据导出为文件。点击"新增导出任务",设置过滤条件后执行,列表中显示每个任务的开始和结束时间、状态、行数和占用空间,如 图 6-14 所示。

导出任务
图 6-14 导出任务

6.4中间表、视图与数据集

6.4.1创建中间表

中间表是在已有数据表基础上加工生成的新表。点击"创建中间表",可以选择两种方式,如 图 6-15 所示:

  • 关联中间表:选择数据后,像搜索一样挑选列、增加公式,生成一张新表,如 图 6-16 所示;
  • 合并中间表:把结构相同的多张表上下合并成一张表。选择或拖入主表,填写中间表名后点击"确定",如 图 6-17 所示。
创建中间表的方式
图 6-15 创建中间表的方式
关联中间表
图 6-16 关联中间表
合并中间表
图 6-17 合并中间表

搜索结果也可以通过"更多 > 保存为中间表"直接生成中间表,见第 2 章。

6.4.2创建视图

点击"创建视图",进入 SQL 视图编辑页面,如 图 6-18 所示。左侧列出可用的数据表,在右侧编辑区输入 SQL 语句:

  • 格式化:整理 SQL 的排版;
  • 清除:清空编辑区;
  • 执行:运行 SQL,下方"数据预览"显示结果;
  • 保存:把 SQL 保存为视图,之后可以像数据表一样使用。
创建视图
图 6-18 创建视图

6.4.3数据集

数据集把多张已关联的表组合成一个整体,方便在搜索时一次选中。在"数据集"页签点击①处"创建数据集"新建,如 图 6-19 所示。在数据搜索中通过"选择数据 > 选择数据集"使用。

数据集
图 6-19 数据集

6.5数据表任务与指标公式

6.5.1数据表任务

"数据表任务"页签集中管理从数据源导入的表的定时导入任务,显示数据源、导入方式、定时导入时间、状态和最近一次导入时间,如 图 6-20 所示。

数据表任务
图 6-20 数据表任务

6.5.2指标公式

"指标公式"页签集中管理在搜索或数据表中创建的指标公式。点击①处"创建指标公式"新建,列表显示指标名、数据类型、来源类型和所属资源,如 图 6-21 所示。

指标公式
图 6-21 指标公式

6.6外部数据源

6.6.1管理数据源

"外部数据源"页签用于连接企业已有的数据库,分为"数据库""API 数据源""HTTP 接入源"三类,如 图 6-22 所示。

外部数据源
图 6-22 外部数据源

点击①处"新增数据源",打开"新增数据源"窗口,如 图 6-23 所示:

  1. 选择数据源类型。支持 PostgreSQL、MySQL(含 MariaDB)、Oracle、IBM DB2、GaussDB 100、SQL Server、Sybase、Greenplum、ClickHouse、Kudu、ElasticSearch、TeraData、MongoDB、Prometheus、Hive、Delta Lake、Iceberg、TiDB、SelectDB / Doris、SAP HANA、ClickZetta、Impala、达梦 DM8、ArgoDB、人大金仓 KingBase 等。
  2. 填写数据源名、服务器地址、端口、数据库名;Schema 不填时使用默认值;需要时填写 JDBC 参数。
  3. 填写数据库的用户名和密码。
  4. 点击"测试连接",连接成功后点击"确定"。
新增数据源
图 6-23 新增数据源

说明:建议为 OT Heavy 单独创建只读的数据库账号,只授予需要分析的库表权限。

6.6.2从数据源导入表

数据源连接成功后,可以把其中的表导入 OT Heavy:

  1. 在数据表列表点击"导入表 > 从数据源导入表",进入导入向导,如 图 6-24 所示。
  2. 第 1 步"选择导入数据源":在下拉框中选择数据源,点击"下一步"。如果还没有数据源,可以点击"去新增数据源"。
  3. 第 2 步"选择需要导入的表":勾选要导入的表。
  4. 第 3 步"配置导入类型的表":设置导入方式,以及是否定时导入。
  5. 完成后,表出现在数据表列表中;如果设置了定时导入,可以在"数据表任务"中查看任务。
从数据源导入表
图 6-24 从数据源导入表

第 7 章数据填报

数据填报用于收集系统里还没有的数据,例如门店巡检结果、库存盘点、计划审批意见等。管理员设计好填报表单后,业务人员在网页上逐条填写提交,数据直接写入对应的数据表,随后就可以在数据搜索、看板和本体中使用。

点击左侧菜单栏的"数据填报"进入本模块。

7.1填报表单列表

填报表单列表如 图 7-1 所示:

  • ① 页签:"填报表单"列出所有填报表;"数据记录"用于查看和管理已提交的数据。
  • ② 创建填报表:新建一张填报表单。
  • ③ 操作按钮:鼠标移到某一行时显示。
填报表单列表
图 7-1 填报表单列表

列表显示每张表的名称、描述、问题数和创建者。操作按钮从左到右如 图 7-2 所示:

编号 按钮 作用
① 填报 打开表单填写数据
② 查看数据表 查看填报数据写入的数据表
③ 编辑 修改表单的字段设计
④ 外部填报链接 生成可在系统外打开的填报链接
⑤ 提交记录 查看这张表单的提交记录
⑥ 删除 删除填报表单
填报表单的操作按钮
图 7-2 填报表单的操作按钮

7.2创建填报表单

  1. 点击"创建填报表",进入表单设计页面,如 图 7-3 所示。

  2. 在①处"表单信息"中填写填报表名和描述。如果提交的数据需要审核后才能写入,打开"开启审核流程";关闭时,提交的数据直接通过并写入数据表。

  3. 在②处"字段设计"中设计题目。每道题需要填写:

    • 问题标题(列名):同时作为数据表中的列名;
    • 题目类型:文本、数值、邮箱、手机号、日期、下拉列表、单选、多选、当前时间;
    • 问题说明:提示填报人应该填写什么;
    • 字段限制:文本可限制字数范围,数值可限制大小范围,留空表示不限制;
    • 必填:勾选后该题必须填写。

    用题目右上角的上、下箭头调整题目顺序。"常用采集"中的邮箱、手机号、生日、职位可以一键添加。

  4. 点击③处"增加字段"添加更多题目。

  5. 右侧④处"填报预览"实时显示表单效果,可以在"PC"和"移动端"之间切换。

  6. 点击⑤处"保存"。

创建填报表单
图 7-3 创建填报表单

提示:页面顶部的"AI 生成表单"可以借助 AI 生成表单字段,生成后仍可按上述方法逐项调整。

7.3填写数据

  1. 在填报表单列表中点击表单名称,或点击该行的"填报"按钮,打开填写页面。
  2. 按题目逐项填写。带"*"的为必填项。例如在"手册示例_门店巡检填报"中,门店填写"上海徐汇店",巡检得分填写"92"。
  3. 填写完成后,点击②处"确认提交",如 图 7-4 所示。需要重新填写时,点击①处"重置"清空内容。
  4. 提交后,可以在"数据记录"页签中查看这条记录,见 7.4 节。
填写数据
图 7-4 填写数据

7.4查看提交记录

点击"数据记录"页签,进入填报记录管理页面,如 图 7-5 所示:

  1. 在左侧"选择填报表"中选择表单,可以按名称搜索。
  2. 在"状态筛选"中按审核状态筛选。
  3. 右侧"填报记录"列表显示提交的数据,标题处显示表单名称、字段数和当前筛选条件。图中是 7.3 节提交的记录:门店"上海徐汇店"、巡检得分 92,由于这张表单没有开启审核流程,审核状态直接为"已通过"。每条记录可以"编辑"或"删除"。
  4. 点击"继续填报"可以接着填写;点击"刷新记录"获取最新提交。
填报记录管理
图 7-5 填报记录管理

7.5外部填报链接

需要让没有系统账号的人员填写时,可以生成外部填报链接:

  1. 在表单所在行点击"外部填报链接"按钮,打开设置窗口,如 图 7-6 所示。
  2. 选择链接有效期:1 天、7 天、30 天或永久有效。
  3. 设置校验码(可点击"随机生成")。设置后,填写人需要输入校验码才能打开表单;不设置则任何拿到链接的人都能填写。
  4. 点击"创建链接",把生成的链接发给填写人。
外部填报链接
图 7-6 外部填报链接

第 8 章定时发送

定时发送可以按设定的时间,把历史问答、数据看板等分析结果自动推送给相关人员。推送渠道包括企业微信、钉钉、飞书的群机器人,企业微信应用,以及电子邮件。

点击左侧菜单栏的"定时发送"进入本模块。页面顶部有四个页签,如 图 8-1 中①处所示:

  • 同步消息:通过群机器人或企业微信应用,把问答或看板的数据推送到工作群;
  • 定时推送:通过电子邮件,把看板等内容以 EXCEL 或 PDF 附件形式定时发送;
  • 机器人管理:维护企业微信、钉钉、飞书的群机器人账户;
  • 应用管理:维护企业微信自建应用账户。
定时发送——同步消息
图 8-1 定时发送——同步消息

使用同步消息前,需要先在"机器人管理"或"应用管理"中添加推送账户;使用定时推送前,需要管理员在"系统管理 > 全局配置"中配置邮件服务器。

8.1添加推送账户

8.1.1群机器人

  1. 进入"机器人管理"页签,在上方选择机器人类型:企业微信群机器人、钉钉群机器人或飞书群机器人,如 图 8-2 所示。
  2. 点击②处"创建机器人",打开添加窗口,如 图 8-3 所示。
  3. 填写机器人名称(可自定义)和 Webhook 地址。以企业微信为例:在企业微信内部员工群中,点击右上角"…",选择"添加群机器人",添加成功后复制 Webhook 地址;如果群里已有机器人,在"查看资料"中复制地址。
  4. 点击"测试账户"检查能否收到消息,然后点击"保存"。
机器人管理
图 8-2 机器人管理
添加企业微信群机器人
图 8-3 添加企业微信群机器人

8.1.2企业微信应用

  1. 进入"应用管理"页签,点击"创建应用",打开添加窗口,如 图 8-4 所示。
  2. 填写应用名称,以及企业微信管理后台中的企业 ID(CorpId)、自建应用的 AgentId 和 Secret。
  3. 在"接收消息成员"中填写接收消息的成员。
  4. 点击"测试账户"检查配置,然后点击"保存"。
添加企业微信应用
图 8-4 添加企业微信应用

8.2创建同步消息任务

  1. 在"同步消息"页签点击"新增任务",打开"增加同步消息任务"窗口,如 图 8-5 所示。
  2. 在左侧填写任务名称,选择推送消息平台:企业微信群机器人、企业微信应用、钉钉群机器人或飞书群机器人,并选择具体的机器人或应用。如果还没有账户,可以点击"去创建机器人"。
  3. 按右侧三个步骤完成配置:
    • 配置绑定资源:选择为消息提供数据的资源,例如某个数据看板中的历史问答;
    • 配置触发条件:设置在什么时间或什么条件下发送;
    • 配置消息内容:编辑推送的文字内容。
  4. 完成后保存任务。任务出现在列表中,显示推送消息平台、创建者、更新时间和状态。
增加同步消息任务
图 8-5 增加同步消息任务

8.3创建定时推送任务

  1. 在"定时推送"页签点击"新增任务",打开"新增定时推送任务"窗口,如 图 8-6 所示。
  2. 填写任务名称。
  3. 推送对象:选择要推送的内容类型(如数据看板)和具体对象。
  4. 推送方式:勾选附件格式 EXCEL 和(或)PDF。
  5. 接收对象:按用户或角色选择接收人,已选的用户和角色显示在下方。
  6. 填写邮件主题和邮件内容。
  7. 设置开始时间(如"配置完成后立即开始执行")和结束时间(如"无限期")。
  8. 设置频率:
    • 简单重复:每隔 N 分钟(1~59)、N 小时(1~23)或 N 天(1~30)执行一次;
    • 明细频率配置:指定每月从第几天开始,在几时几分几秒执行。
  9. 需要时设置"失败重试",然后点击"确定"。
新增定时推送任务
图 8-6 新增定时推送任务

说明:定时推送通过电子邮件发送,请先确认管理员已在"系统管理 > 全局配置"中开启并配置邮件系统。

第 9 章资源管理

资源管理用"项目"来组织历史问答、数据看板、数据应用和数据表。可以按部门或业务主题建立项目,把相关资源归到一起,方便查找和共享;项目还可以嵌套建立子项目。

点击左侧菜单栏的"资源管理"进入本模块。

9.1资源列表

资源管理页面如 图 9-1 所示:

  • ① 项目栏:顶部是搜索框;"所有"显示全部资源,下方列出已建立的项目,点击项目名称只显示该项目中的资源。
  • ② 资源类型页签:所有、历史问答、数据看板、数据应用、数据表。
  • ③ 创建:新建项目或各类资源。
  • ④ 导入:导入从本系统导出的问答或看板文件。
资源管理
图 9-1 资源管理

资源卡片的操作方法与历史问答相同,见第 4 章。

9.2创建项目

  1. 点击"创建",在下拉菜单中选择①处"项目",如 图 9-2 所示。菜单中的其他选项可以直接新建历史问答、数据看板、数据应用、中间表,或者导入数据表。
  2. 在"创建项目"窗口中,选择父项目(不选则为顶层项目),填写项目名和描述,如 图 9-3 所示。
  3. 点击"确定"。新项目会显示在左侧项目栏中;如果选择了父项目,则嵌套显示在父项目下。
创建菜单
图 9-2 创建菜单
创建项目
图 9-3 创建项目

9.3把资源放入项目

有两种方法把资源放入项目:

  • 保存历史问答时,在"管理项目"中选择项目(见第 2 章);
  • 在问答、看板等资源卡片上点击"移动"按钮,在"移动数据看板"等窗口中选择目标项目,点击"确定"。

放入后,在左侧项目栏点击项目名称,即可看到项目中的资源,如 图 9-4 所示。鼠标移到项目名称上,右侧的图标可以编辑或删除项目。

项目中的资源
图 9-4 项目中的资源

9.4导入资源

点击"导入",打开"导入资源"窗口,如 图 9-5 所示:

  1. 在"资源文件"中选择从本系统导出的问答或看板文件。
  2. 在"资源同名时处理方式"中选择遇到同名资源时如何处理,例如"跳过"。
  3. 在"管理项目"中选择导入到哪个项目。
  4. 点击"确定"。
导入资源
图 9-5 导入资源

第 10 章本体管理

本体是围绕一个业务主题组织起来的知识空间。它把相关的数据表、业务文档、指标和分析看板绑定在一起,并配有一个"本体智能体":用户用自然语言提问时,智能体会结合本体中的数据和文档给出有依据的回答,还可以调用执行项完成分析或写回操作。

本章以系统预置的"闭环Demo-采购审批流程挖掘与优化"本体为例进行介绍。点击左侧菜单栏的"本体管理"进入本模块。

10.1界面概览

本体管理页面如 图 10-1 所示:

  • ① 创建:新建本体。上方显示已有本体数量和还可以创建的数量。
  • ② 本体与模块:左侧列出所有本体,展开某个本体后显示它的 11 个模块:智能体、本体图谱、文档中心、数据表、数据探索、问答列表、数据看板、数据应用、指标中心、执行中心、控制面板。
  • ③ 工作区:显示所选模块的内容。
本体管理
图 10-1 本体管理

10.2创建本体

  1. 点击"创建",打开"创建本体"窗口,如 图 10-2 所示。
  2. 填写本体名称,在"图标"中选择一个图标,下方"预览"显示效果。
  3. 点击"确定"。新本体出现在左侧列表中。
  4. 依次在"数据表"模块导入相关数据表,在"文档中心"上传业务文档,即可开始使用智能体。
创建本体
图 10-2 创建本体

10.3智能体

"智能体"模块是与本体对话的地方,如 图 10-3 所示:

  1. 在下方输入框中输入问题,例如"高金额采购申请中,有哪些跳过了法务审核?",按 Enter 或点击"发送"。
  2. 智能体会读取本体中的数据表和文档,逐步处理,处理过程中可以点击"停止任务"中断。
  3. 回答完成后,下方的"执行摘要"显示处理步骤数和最后一步的状态。点击④处"查看处理过程"可以展开每一步,了解智能体查询了哪些数据、调用了哪些工具。涉及数据查询时,回答中会列出明细数据,并在"数据来源"中列出用到的数据表。

图 10-3 中是对"我有哪些本体可查?"的回答:智能体说明当前对话绑定在本体"闭环Demo-采购审批流程挖掘与优化"上,并介绍可以查询的资源;执行摘要显示共 6 步,最后一步"完成"。

页面顶部的按钮:

  • ① 会话:查看和切换历史会话;
  • ② 知识库:打开"智能体知识库"窗口,为智能体绑定知识库。绑定后的知识库会作为智能体的只读证据来源;
  • ③ 清空上下文:开始新的话题,智能体不再参考之前的对话。
本体智能体
图 10-3 本体智能体

首页的"与本体对话"使用的也是这里的智能体,见第 1 章。

10.4本体图谱

"本体图谱"以网络图展示本体中的数据表、文档、字段等知识节点以及它们之间的关系,顶部显示节点和关系的总数,如 图 10-4 所示。

  • 全局图:显示整个本体的图谱,可以拖动、缩放,用右上角搜索框查找节点;
  • 业务案例:按业务案例生成的图谱,点击"生成"创建;
  • 路径解释:查看节点之间的关联路径;
  • 图谱质量:检查图谱的完整性,如 图 10-5 所示,包括节点数、关系数、孤立节点、连通分量、未映射提及和失败来源;
  • 重建、刷新:数据或文档变化后,重新生成或刷新图谱。
本体图谱——全局图
图 10-4 本体图谱——全局图
本体图谱——图谱质量
图 10-5 本体图谱——图谱质量

10.5文档中心

"文档中心"管理本体绑定的业务文档,例如口径说明、业务规则、操作规程,如 图 10-6 所示。

  1. 点击"上传文档"上传文件。
  2. 列表显示文件名、类型、大小、关联表、更新时间和处理状态。状态为"已完成"时,文档内容已经可以被智能体检索和引用。
  3. 在"操作"列中,点击眼睛图标查看文档内容,点击垃圾桶图标删除文档。
文档中心
图 10-6 文档中心

10.6数据表与数据探索

"数据表"模块列出本体绑定的数据表,如 图 10-7 所示。点击"导入数据表"可以从系统中选择更多的表加入本体;"关联关系"页签用于设置这些表之间的连接,方法与第 6 章相同。

本体中的数据表
图 10-7 本体中的数据表

"数据探索"模块提供与"数据搜索"相同的搜索功能,但只能选择本体中的数据表,如 图 10-8 所示。操作方法见第 2 章。

数据探索
图 10-8 数据探索

10.7问答列表、数据看板与数据应用

这三个模块分别管理属于本体的历史问答、数据看板和数据应用,用法与 BI 工作台中的对应功能相同(见第 4、5 章)。此外,"问答列表"可以通过"导入外部历史问答"把 BI 工作台中已有的问答引入本体,"数据看板"和"数据应用"也有对应的导入入口,如 图 10-9 所示。

问答列表
图 10-9 问答列表

10.8指标中心

"指标中心"用于关注重要指标并按时推送,如 图 10-10 所示。点击"新增指标",打开"新增指标"窗口,如 图 10-11 所示:

  1. 填写指标标题。
  2. 在"选择指标"中选择要关注的指标;点击"增加指标"可以同时关注多个。
  3. 设置推送时间:可以"简单重复"(每隔 N 分钟、N 小时或 N 天),也可以"明细频率配置"(每月从第几天开始,在几时几分执行)。
  4. 点击"确定"。
指标中心
图 10-10 指标中心
新增指标
图 10-11 新增指标

10.9执行中心

执行项是可以由智能体或用户触发运行的 Python 脚本,用于完成计算、检测、写回等操作。"执行中心"列出本体中的执行项及其说明、开始时间和结束时间,如 图 10-12 所示。例如,示例本体中的"Demo_流程挖掘_合规偏差检测"会校验高金额跳过法务、付款早于验收等偏差。

执行中心
图 10-12 执行中心

点击"新增执行项",打开"新增执行项"窗口,如 图 10-13 所示:

  1. 填写名称和描述。
  2. 在"Python 脚本"中编写脚本,在"参数(JSON)"中填写运行参数,可以点击"格式化"整理 JSON。
  3. 点击"校验语法"检查脚本,点击"测试运行"试运行。
  4. 确认无误后点击"保存";点击"清除"清空内容。

也可以点击"AI 生成脚本",描述需求后由 AI 生成脚本草稿,再按上述步骤校验和保存。

新增执行项
图 10-13 新增执行项

注意:执行项会实际读取或修改数据,请在测试运行确认结果正确后再保存,并只授权给需要的人员使用。

10.10控制面板

控制面板是面向业务人员的操作界面,把本体中的数据以卡片形式展示,并提供可以直接执行的业务动作。"控制面板"模块的列表显示每个面板的名称、说明、任务目标、卡片和同步状态,如 图 10-14 所示。

  • 点击"新增控制面板"手动创建,或点击"AI 生成控制面板"根据描述自动生成;
  • 在"操作"列中,"查看"打开面板,"打开卡片"查看面板中的卡片,"修改"编辑面板。
控制面板列表
图 10-14 控制面板列表

在列表中点击"查看"打开控制面板。示例面板"采购审批流程挖掘闭环控制面板"包含采购申请概览、路径变体、瓶颈活动边、合规偏差、任务与审计等卡片:

  • 刷新:重新查询所有卡片,获取最新数据。
  • 显示方式:每张卡片可以在"表、柱、线、饼"之间切换,即表格、柱状图、折线图、饼图。切换只改变当前显示,重新打开面板后恢复原来的显示方式。卡片上同时显示数据的行数。
  • 执行按钮:列出可执行的业务动作,示例面板中有重新挖掘、生成整改任务、要求补证、关闭偏差、重开偏差、导出日志。"当前对象"显示动作将要处理的记录;在任一卡片中点击一条记录,当前对象随之改为该记录,再点击相应动作执行。
  • 编辑源码:打开面板编辑页面,可以修改面板的名称、说明、任务目标和源码(JSON 格式),也可以用"AI 修改当前面板"生成修改草稿,校验预览后再应用。

注意:执行按钮会对"当前对象"实际执行业务动作,例如生成整改任务、关闭偏差,点击前请确认当前对象是要处理的记录。

第 11 章日志管理

日志管理记录系统中的各类操作,例如登录、导入数据表、新建项目、修改看板等,用于审计和问题追溯。查看日志需要具有日志管理员或系统管理员权限。

点击左侧菜单栏的"日志管理"进入"操作日志"页面,如 图 11-1 所示:

  • ① 筛选条件:可以按关键词、主机服务器、操作用户、用户姓名筛选;
  • ② 更多筛选:按状态(成功或失败)、操作类型(如问答、看板、数据表、项目、登录中心、系统管理等)、开始时间和结束时间筛选;
  • ③ 分页:列表底部显示总页数,可以翻页或跳转到指定页。
操作日志
图 11-1 操作日志

列表中每条日志包括:主机服务器、操作类型、状态、详情、操作用户、用户姓名和操作时间。"详情"列记录了具体操作,例如"从文件导入表'手册示例_门店月度销售'"或"新增项目'手册示例_销售分析'"。

提示:排查登录问题时,可以把"类型"设为"登录中心"、"状态"设为"失败",查看失败原因,例如"用户名或密码错误"。

第 12 章数据治理

数据治理帮助管理员掌握系统中的数据资产情况,并把数据以 API 或 JDBC 的方式安全地提供给其他系统使用。页面顶部有"资产目录""资产全景""数据服务API"三个页签。

点击左侧菜单栏的"数据治理"进入本模块。

12.1资产目录

"资产目录"按数据源展示所有数据表。左侧树形列表列出数据源(如 Local)及其中的表数量;中间的圆柱图标显示该数据源的表总数、已建关联的表数和孤立表数;右侧以卡片列出数据源中的表,点击"更多"查看表的详细信息。可以用左上角的搜索框查找表。

12.2资产全景

"资产全景"以统计图展示数据资产的整体情况,如 图 12-1 所示,包括接入数据源数、磁盘空间占用、数据表数、问答数、看板数、轮播看板数、数据应用数、卡片数、任务数和数据服务 API 数。各项统计可以选择时间范围(如近 30 天),下方可以按日筛选查看资源总数等明细。

资产全景
图 12-1 资产全景

12.3数据服务 API

"数据服务API"把系统中的数据表发布为接口,供其他系统调用,如 图 12-2 所示。下设"API 列表""服务分组""JDBC 服务""用量治理""使用说明"等子页签。

数据服务 API
图 12-2 数据服务 API

12.3.1新增数据 API

  1. 在"API 列表"中点击"新增数据API",打开窗口,如 图 12-3 所示。
  2. 填写 API 名称(1~45 个字符)。
  3. 选择要发布的数据表,以及所属服务分组(分组在"服务分组"中维护)。
  4. 设置服务状态是否启用,点击"确定"。
新增数据 API
图 12-3 新增数据 API

API 发布后,列表中显示它的数据表名、所属服务分组、平均响应时长、调用次数、成功率和服务状态。"用量治理"用于查看和控制各接口的调用量,"使用说明"介绍调用方法。

12.3.2JDBC 服务

"JDBC 服务"让 BI 工具或程序通过 JDBC 连接读取系统中的表,如 图 12-4 所示。页面顶部显示本系统的 JDBC 网关地址;点击"新增JDBC服务",设置服务名称和对外暴露的表即可。列表显示每个服务的标签、暴露表、调用次数和连接状态。

JDBC 服务
图 12-4 JDBC 服务

说明:对外提供数据前,请确认只暴露必要的表,并按"系统管理 > 接口鉴权"的要求配置访问凭证。

第 13 章DataSpring ETL

DataSpring 是 OT Heavy 集成的流批一体 ETL 平台,用于把数据从各种来源抽取出来,经过过滤、转换、校验后,加载到目标系统。处理逻辑以"任务流"的形式编排:在画布上放置处理器并用连线串起来,就组成一条任务流,可以手动运行,也可以定时运行。

点击左侧菜单栏的"DataSpring ETL"进入本模块。

13.1页面介绍

DataSpring 的首页是任务流列表,如 图 13-1 所示:

  • ① 页签:任务流、算子、定时、运行日志、操作日志、设置。
  • ② 新建任务流:创建一条新的任务流,见 13.2 节。
  • ③ 筛选:按名称搜索,按处理模式、运行状态筛选;右侧按钮刷新列表。
  • ④ 操作:鼠标移到某一行时,从左到右依次为"创建副本""修改""运行任务流"和删除按钮。点击删除按钮后,系统提示"任务流删除后不可恢复",点击"确认删除"才会删除。
任务流列表
图 13-1 任务流列表

列表显示每条任务流的名称、描述、处理模式、运行状态、更新时间和创建者。点击名称即可打开它的编辑面板。

任务流有以下几种运行状态:

状态 说明
初始态 新建任务流后的默认状态
等待运行 点击运行后,任务流排队等待调度
运行中 排队结束,正在处理数据
已完成 所有处理器都已正常运行完成
失败 运行中遇到异常,任务流无法继续
已取消 运行中被手动取消

13.2创建任务流

  1. 点击"新建任务流",打开"创建任务流"窗口,如 图 13-2 所示。
  2. 在①处填写任务流名称,例如"手册示例_城市销售汇总"。
  3. 在②处填写描述(可选)。
  4. 在③处选择处理模式,见下表。
  5. 保留④处"创建后自动进入编辑面板"的勾选,点击⑤处"创建"。
创建任务流
图 13-2 创建任务流
处理模式 适用场景
批处理 典型的 ETL 模式,适合数据转换、实时性要求不高的周期性任务。运行时从抽取器开始依次执行下游处理器,全部执行完后结束
流处理 适合与实时系统集成。运行后所有处理器一直处于运行状态,即时处理数据
同步流 适合多表同步、整库同步,以及同步过程中表结构有变化的场景
数据验证 用于比对目标表与源表的数据,发现并订正不一致

13.3编排任务流

13.3.1编辑面板

任务流的编辑面板如 图 13-3 所示:

  • ① 处理器面板:左侧顶部显示任务流名称和处理模式("批"表示批处理),下面按类别列出可用的处理器:抽取器、过滤器、转换器、验证器、加载器,可以按关键词搜索。点击"隐藏左侧栏"可以收起这一栏。
  • ② 画布:把处理器拖到这里,并用连线连接。
  • ③ 顶部按钮:从左到右为"运行设置"(设置各处理器的并行度)、运行历史、"事件检查器"、任务流状态和"运行任务流"。
  • ④ 画布工具:开启流式动画、缩放比例、重置、放大、缩小、自适应缩放比例、自动布局和 Zen mode(专注模式)。左下角另有"隐藏底部栏"和"搜索处理器"。
  • ⑤ 底部栏:"任务流实时日志"记录任务流和各处理器的状态变化,"处理器预览数据"显示处理结果。
任务流编辑面板
图 13-3 任务流编辑面板

处理器分为五类:

类别 作用 示例
抽取器 从数据源读取数据 DataFocus、本地表(上传文件)、MySQL、Oracle、PostgreSQL、SQL Server、Doris、SelectDB、StarRocks、达梦、OceanBase、Mongo、InfluxDB、TDEngine、Kafka、Mqtt 等
过滤器 按条件筛选数据 Flink 过滤器
转换器 对数据进行计算、关联、合并 SQL 转换器、Join 转换器、Union 转换器、Flink 转换器、Pipeline 转换器
验证器 校验数据 数据校验器
加载器 把结果写入目标系统 DataFocus、本地表、MySQL、Oracle、PostgreSQL、Doris、Elasticsearch、Kafka 等

13.3.2添加处理器与连线

  1. 从处理器面板中把处理器拖到画布上。画布上的处理器显示名称和一个随机编号,例如"本地表抽取器(pYOux)",下方有"编辑"和"输出"两个按钮。
  2. 点击"编辑",配置处理器的数据来源或处理规则。
  3. 处理器右侧的圆点是输出端,左侧的圆点是输入端。按住上游处理器的输出端,拖到下游处理器的输入端,即可连线。每个输入端只能连接一条线。
  4. 点击"输出",管理处理器的输出表结构,并设置主键,见本节"设置输出与主键"。

下面以"手册示例_城市销售汇总"为例,搭建一条"本地表抽取器 → SQL 转换器 → 本地表加载器"的批处理任务流:读取门店月度销售文件,按城市汇总订单数和销售额,输出为 CSV 文件。

13.3.3配置抽取器

本例使用"本地表抽取器",直接上传数据文件:

  1. 把"本地表抽取器"拖到画布上,点击"编辑",打开"上传文件"窗口,如 图 13-4 所示。
  2. 在①处选择文件类型:CSV、Excel(.xls、.xlsx)或 JSON。需要时点击②处"配置解析规则"。
  3. 点击或把文件拖到上传区域,文件需小于 16M。上传后④处显示文件名,例如"手册示例_门店月度销售.csv"。
  4. 点击③处"解析文件"。
上传文件
图 13-4 上传文件

解析完成后进入"修改导入信息",如 图 13-5 所示:

  1. 系统列出每一列的列名、识别出的数据类型和首行数据。取消勾选可以不导入某一列,也可以修改列名。
  2. 在①处检查每列的数据类型,必要时修改。本例把"销售额"从自动识别的 FLOAT 改为 DOUBLE。
  3. 点击②处"预览数据"可以查看解析结果。
  4. 点击③处"保存"。
修改导入信息
图 13-5 修改导入信息

提示:FLOAT 是单精度类型,金额等需要精确计算的列请改为 DOUBLE 或 DECIMAL,否则汇总结果会有误差。本例中如果保留 FLOAT,上海的销售额合计会算成 851935.6,而实际是 851935.68。

从数据库读取数据时,选择对应的抽取器(如 MySQL 抽取器),填写连接信息后选择表。"DataFocus 抽取器"用于读取 OT Heavy 中的数据表,需要填写 DataFocus 主机地址、租户号以及 Secret ID 和 Secret Key;如果没有密钥,请联系系统管理员。

13.3.4配置 SQL 转换器

  1. 把"SQL 转换器"拖到画布上,从抽取器的输出端连线到它的输入端。

  2. 点击 SQL 转换器的"编辑",打开配置窗口,如 图 13-6 所示。

  3. ①处"上游信息"列出已连接的上游处理器及其字段。SQL 转换器最多可以连接 5 个上游,未连接的显示为"sql_in_2 未连接"等。

  4. 在②处输入 SQL 语句。引用上游数据时,用上游处理器的完整名称作为表名,并用反引号括起来,例如:

    SELECT `城市`, SUM(`订单数`) AS `订单数合计`,
           CAST(SUM(`销售额`) AS DECIMAL(12, 2)) AS `销售额合计`
    FROM `本地表抽取器(pYOux)`
    GROUP BY `城市`
    
  5. ③处三个按钮依次为"SQL 中支持的函数""SQL 中关键词"和"打开预设"。预设可以保存常用的 SQL 语句。

  6. 点击④处"保存"。系统会检查语法,正确时提示"保存成功";有错误时显示"SQL 语法错误"及原因,例如表名写错时提示找不到对象。

SQL 转换器
图 13-6 SQL 转换器

13.3.5设置输出与主键

每个处理器的输出都需要设置主键,否则任务流无法运行。抽取器读取的表没有主键时,系统自动使用 flink_uuid 列作为主键;转换器、加载器的输出需要手动设置。

  1. 点击处理器的"输出",打开输出窗口,如 图 13-7 所示。
  2. ①处"配置生成表"是根据配置自动生成的表结构,②处"输出表"是传给下游处理器的表结构。可以在生成表中勾选列,点击"批量导入"加入输出表;输出表中的列可以点击修改列名,或"删除"。
  3. 鼠标移到输出表中作为主键的列上,点击列名后的钥匙按钮(③处,提示"设为主键")。设置后钥匙变为紫色,再次点击可以取消主键。本例把"城市"设为主键。
  4. 点击"溯源"可以查看该列在整条任务流中从哪里来。
  5. 点击"关闭"。
设置输出与主键
图 13-7 设置输出与主键

13.3.6配置加载器

  1. 把"本地表加载器"拖到画布上,从 SQL 转换器的输出端连线到它的输入端。
  2. 点击"编辑","文件格式"选择 CSV,点击"保存"。本地表加载器把结果保存为文件,运行完成后可以下载。
  3. 如果加载器的输出还没有主键,按上一节的方法设置。

要把结果写入数据库或 OT Heavy,选择对应的加载器并填写连接信息。

13.3.7异常事件检查器

点击顶部的"事件检查器"按钮(图 13-8 中②处),右上角显示"异常事件检查器"(①处),列出各处理器存在的问题。点击检查器标题右侧的刷新图标"重新检查",可以在修改配置后重新检查。

异常事件检查器
图 13-8 异常事件检查器

图中 SQL 转换器有两条异常:"输出表: out 没有链接"表示它还没有连接下游处理器;"输出表: out 未设置主键"表示还没有设置主键。常见的异常还包括处理器未配置、输入表没有链接、列溯源失败等。有错误级别的异常时,点击"运行任务流"会提示"处理器配置有异常",任务流不会运行。所有异常处理完后,检查器显示"暂无异常"。

13.4运行任务流

  1. 确认异常事件检查器显示"暂无异常",点击右上角的"运行任务流"按钮。也可以在任务流列表中点击该行的"运行任务流"按钮。
  2. 任务流依次进入"等待运行""运行中",完成后状态显示"已完成",如 图 13-9 中①处所示。本例耗时约两分半钟。
  3. 运行过程中,每个处理器右上角显示自己的状态,连线变为绿色(②处);底部"任务流实时日志"记录每次状态变化(④处)。
  4. 本地表加载器的图标变为下载图标(③处),提示"点击下载"。点击后下载结果文件,文件名为"加载器名称_运行时间_序号.csv"。
运行完成的任务流
图 13-9 运行完成的任务流

13.4.1预览数据

双击画布上的处理器,底部栏切换到"处理器预览数据",显示该处理器的处理结果,最多 100 条,如 图 13-10 所示。点击列名可以排序,左右拖动列名可以调整列的顺序。

处理器预览数据
图 13-10 处理器预览数据

本例的汇总结果为:上海 8323 单、销售额 851935.68;南京 3532 单、402141.89;杭州 3671 单、415554.94,与原始文件逐行相加的结果一致。

提示:处理器的表结构改变后,例如修改了列的数据类型,需要到相关处理器的"输出"中检查输出表。如果异常事件检查器提示某列"溯源失败",删除输出表中的旧列,再从生成表中重新导入。被下游使用的列不能直接删除,系统会提示"有下游依赖"。

13.5定时

需要定期运行的任务流,可以在"定时"页签中创建定时计划:

  1. 点击"定时"页签,再点击"创建定时计划",打开"创建定时任务"窗口,如 图 13-11 所示。
  2. 填写名称和描述,例如"每周日广告转化分析"。
  3. 在"目标任务流"中选择要定时运行的任务流。同一条任务流只能设置一个定时任务。
  4. 在"计划的时间范围"中选择起始时间和结束时间。
  5. 选择类型:
    • 简单重复执行:按固定间隔执行;
    • 明细频率设置:设置执行时间(几点几分)、执行日(如每周哪几天)和执行月;
    • 只执行一次:在指定时间执行一次。
  6. 点击"创建"。
创建定时任务
图 13-11 创建定时任务

定时运行的结果同样记录在"运行日志"中。

13.6算子

"算子"页签管理自定义算子,如 图 13-12 所示。自定义算子可以在转换器的公式中使用,用来补充系统内置函数无法完成的计算。系统支持两种算子:

  • ① 新建 UDF 算子:用 Python 编写 Flink UDF,需要一定的编程能力。
  • ② 新建表达式算子:用公式定义算子,输入公式时有代码补全。
算子列表
图 13-12 算子列表

点击"新建 UDF 算子"打开编辑窗口,如 图 13-13 所示。填写名称和描述,在"函数"中编写 Python 代码(窗口中预置了一个示例),也可以在"AI 辅助"中描述需求,点击"生成 UDF"自动生成代码。完成后点击"创建"。

新建 UDF 算子
图 13-13 新建 UDF 算子

13.7运行日志与操作日志

"运行日志"列出每次运行的记录,如 图 13-14 所示,包括任务流名称、运行状态、执行时间和用时。可以按任务流名称、运行结果和开始区间筛选。点击"查看详情"可以看到这次运行的总体状态、运行时间和耗时。

运行日志
图 13-14 运行日志

"操作日志"记录对任务流的新增、执行、删除等操作,如 图 13-15 所示,包括主机地址、类型、状态、内容和操作时间,可以按操作类型、操作结果和时间范围筛选。操作失败时,"内容"中会写明原因,例如任务流正在编辑时不能删除。

操作日志
图 13-15 操作日志

13.8设置

"设置"页签包括"邮箱配置""全局配置""设备授权信息"和"主题配置",如 图 13-16 所示。"邮箱配置"用于设置 DataSpring 发送邮件所用的邮件服务器:打开"是否启用邮件系统配置"后,填写系统域名、服务器、端口、发送邮箱、用户名和密码,按需启用 SSL,点击"保存"。

DataSpring 设置
图 13-16 DataSpring 设置

第 14 章系统管理

系统管理供系统管理员使用,用于管理用户、角色和权限,以及完成系统的各项配置。点击左侧菜单栏的"系统管理"进入本模块。

页面顶部有 12 个功能页签,如 图 14-1 中①处所示:组织架构、权限管理、全局配置、搜索配置、知识库、定时更新、公式、接口鉴权、外部 Agent、授权用量、主题配置、推荐配置。

14.1组织架构

"组织架构"页签下有②处所示的"用户列表""组织架构""角色""AD/LDAP服务器"四个子页签。

14.1.1用户管理

"用户列表"显示系统中的用户,可以按角色筛选、按名称搜索,点击"导出用户"导出用户清单,如 图 14-1 所示。

用户列表
图 14-1 用户列表

新增用户:

  1. 点击③处"新增用户",打开"增加用户"窗口,如 图 14-2 所示。
  2. 填写用户名和初始密码。
  3. 选择部门岗位和用户角色。
  4. 点击"了解更多"展开后,可以填写真实名称、邮箱和手机号。
  5. 点击"确定"。

批量导入用户:点击④处"批量导入用户",按模板填写用户信息后一次性导入。

增加用户
图 14-2 增加用户

14.1.2角色

"角色"子页签列出系统中的角色及其描述,如 图 14-3 所示。系统预置角色不允许修改,常用的有:

角色 说明
系统管理员 全局配置、用户管理、角色管理,分配角色到用户或岗位
资源管理员 管理所有资源,为资源赋予权限
部门管理员 管理自身所在部门的组织架构,可以把自己拥有的角色分配给所管理的组织
开发者 新增资源,管理拥有权限的资源
日志管理员 审计日志

此外还有面向外部 Agent 的 MCP 系列角色(如 MCP 脚本运行管理员、MCP 填报设计管理员)和级联调度相关角色。点击"新增角色"可以创建自定义角色。

角色
图 14-3 角色

14.1.3AD/LDAP 服务器

如果企业使用 AD 或 LDAP 统一管理账号,可以在"AD/LDAP服务器"子页签点击"添加服务器",填写服务器名称、基础 DN 等信息,把企业账号同步到系统中,如 图 14-4 所示。

AD/LDAP 服务器
图 14-4 AD/LDAP 服务器

14.2权限管理

"权限管理"用于给自定义角色分配资源权限,如 图 14-5 所示:

  1. 在左侧"所有角色"中选择一个自定义角色;如果还没有,点击"新增角色"创建。
  2. 右侧"各个资源的权限配置"按"所有资源""本体""数据填报"分类列出资源,勾选"只显示有权限的"可以只看已授权的资源。
  3. 为角色勾选对各资源的权限,保存后,拥有该角色的用户即获得相应权限。
权限管理
图 14-5 权限管理

14.3全局配置

"全局配置"集中管理系统级参数,如 图 14-6 所示。子页签包括:基础配置、企业微信配置、钉钉配置、飞书配置、千帆玉符配置、地理位置配置、插件图形、提示词管理、韬问同步配置、自定义 AI、功能裁剪、邮件模板、规格配置、单点登录、系统标签、看板顺序、其他配置。

"基础配置"中最重要的是邮件系统:开启"是否启用邮件系统配置",填写邮件服务器、端口、发送邮箱、用户名、密码,根据服务器要求选择是否启用 SSL,然后点击"保存"。

全局配置——基础配置
图 14-6 全局配置——基础配置

注意:强烈建议配置邮件系统,否则找回密码、定时推送等需要发送邮件的功能无法正常使用。

14.4搜索配置

"搜索配置"让数据搜索更贴合企业的业务习惯,如 图 14-7 所示,包括:

  • 自定义位置:定义区域范围(如"华东大区"包含哪些省市),搜索时可以用它圈定范围;也可以"按国家导入系统位置";
  • 自定义日期:定义企业自己的日期口径,例如财年;
  • 自定义列中值的同义词、自定义关键词:在全系统范围内设置同义词和关键词(单张表的设置见第 6 章"搜索扩展");
  • 其他配置:其他搜索相关参数。
搜索配置
图 14-7 搜索配置

14.5知识库

"知识库"管理小慧使用的知识,如 图 14-8 所示:

  • 小慧标记知识:用户在搜索中纠正或确认过的"自然语言问题—关键词语句"对应关系,可以按知识分类查看和维护;
  • 用户个人知识、系统知识库:分别管理个人和全系统共享的知识;
  • 知识库批量导入、全部批量导入任务:批量导入知识并查看导入任务;
  • 知识分类:维护知识的分类。
知识库
图 14-8 知识库

14.6其他系统设置

页签 用途
定时更新 新增和管理系统级的定时更新任务
公式 新增自定义公式,供全系统的搜索和指标使用
接口鉴权 管理第三方接口鉴权、承载令牌和本体场景审批
外部 Agent 配置外部 Agent(通过 MCP 接入)可以发起哪类写操作,以及 Agent 变更审批和 MCP 数据管理员授权
授权用量 查看设备授权信息,以及大模型 Token 按天、按月的消耗量
主题配置 选择主题风格(默认、商务)、主题色(经典蓝、荷叶绿、宝石蓝、活力红或自定义)和头部导航背景
推荐配置 设置首页推荐和小慧首页推荐,可以按数据表添加多组推荐组合

其中"外部 Agent"页签需要特别说明:外部 Agent 实际能写入的范围,是本页配置的"外部 Agent 操作能力"、OAuth 授权范围和系统资源编辑权限三者的交集,如 图 14-9 所示。这里不会另建一套资源权限,数据表、本体、项目等的访问范围仍由权限管理统一控制。

外部 Agent
图 14-9 外部 Agent

第 15 章回收站

删除的数据看板、数据应用和卡片会先进入回收站,在这里可以恢复或彻底删除。历史问答删除后不进入回收站。

点击左侧菜单栏的"回收站"进入本页面,如 图 15-1 所示:

  • ① 类型页签:所有、数据看板、数据应用、卡片;
  • ② 恢复全部:把回收站中的全部资源恢复到原来的位置;
  • ③ 清空:彻底删除回收站中的全部资源。
回收站
图 15-1 回收站

页面右上角可以按名称搜索,或在卡片和列表两种显示方式之间切换。

注意:在回收站中彻底删除或清空后,资源无法再恢复,请谨慎操作。